[Trilinos-Users] Teuchos link error with Xcode [SOLVED]

Roberts, Nathan V. nvroberts at alcf.anl.gov
Thu Jul 16 12:30:44 EDT 2015

In case you are not aware of it: CMake has options for generating Xcode projects.  In general, you can take your CMake command and add a

 -G "Xcode"

option, and this will generate a project for you.  I use this all the time for Camellia (which is built atop Trilinos, and uses CMake as its build system).  This is a pretty great setup for me, as I can use Xcode's (really quite good) code completion, visual debugger, etc.  Xcode even does smart things with doxygen documentation, so that you can get overlaid documentation as you write your code.

Also very useful to me: it is possible to use Xcode to do visual debugging of (small) MPI runs.  Simply do an MPI Barrier at the top of your driver and set a breakpoint there.  Set the Xcode scheme to wait for launch, and then do e.g.

mpirun -np 4 ./path/to/my/driver/Debug/MyDriver

Xcode will detect the launch of one of the MPI processes, break on the Barrier, and then you can manually attach to the other processes using Debug > Attach to Process within Xcode.  Continue once you've attached to all of them.



On Jul 15, 2015, at 3:44 AM, Sensei <senseiwa at gmail.com<mailto:senseiwa at gmail.com>> wrote:

I know, Mark, in previous projects I could use CMake and I was happy as a clam. Right now I need to stick with Xcode and discard CMake/Make.

The problem was solved by rebuilding Trilinos, apparently it used an old version of MPI and after updating OpenMPI it broke somehow.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://trilinos.org/pipermail/trilinos-users/attachments/20150716/0fa823a5/attachment.html>

More information about the Trilinos-Users mailing list