[Trilinos-Users] ctest -j4 error

Baker, Christopher G. bakercg at ornl.gov
Tue Apr 5 03:34:50 MDT 2011

That is good news.

This test, CXX_COMPLEX_BLAS_WORKS, determines whether there is an incompatibility on the system regarding the interface for returning complex numbers from routines. Specifically, it determines whether the BLAS routine cdotc (single-precision complex dot product) operates as expected. If it doesn't (on OS X computers, for example; and in your case), then it employs a known fix (an alternate passing mechanism). However, in your case, that doesn't work either. That could be because of some other underlying problem with the BLAS, although I suspect not, because double-precision complex dot product seems to work (as evidenced by the passing tests in Anasazi_Tpetra_MVOPTester and Belos_Tpetra_MVOPTester). It seems to be limited to the single-precision routine.

Which BLAS/LAPACK library are you using? Can you provide your ./do-configure script? What type of system do you have? What compilers/version are you using to build Trilinos, and if you built your own BLAS/LAPACK, what compilers/version did you use?


On 4/5/11 5:14 AM, "narendiran kumar" <narendirankumar at gmail.com<mailto:narendirankumar at gmail.com>> wrote:

Dear Sir,

FYI, Also I have attached CMakeCache.txt file.  And also i have to mention one point that, while i tried "./do-configure", it shows that

//Result of TRY_COMPILE
//Result of TRY_RUN
//Result of TRY_COMPILE
//Result of TRY_RUN

*** do-configure run time failed notices ****

Configuring individual enabled Trilinos packages ...

Processing enabled package: TrilinosFramework (tests, examples)
Processing enabled package: Teuchos (tests, examples)
-- Performing Test HAVE_GCC_ABI_DEMANGLE
-- Performing Test HAVE_GCC_ABI_DEMANGLE - Success
-- Performing Test HAVE_TEUCHOS_BLASFLOAT - Success
-- Performing Test CXX_COMPLEX_BLAS_WORKS - Failed
Processing enabled package: ThreadPool (tests, examples)
Processing enabled package: Sacado (tests, examples)
-- Performing Test HAS_C99_TR1_CMATH
-- Performing Test HAS_C99_TR1_CMATH - Failed
Processing enabled package: RTOp (tests, examples)
Processing enabled package: Kokkos (tests, examples)
Processing enabled package: Epetra (tests, examples)
Processing enabled package: Zoltan (tests, examples)
Processing enabled package: Shards (tests, examples)
Processing enabled package: GlobiPack (tests, examples)
Processing enabled package: Triutils (tests, examples)
Processing enabled package: Tpetra (tests, examples)
Processing enabled package: EpetraExt (tests, examples)
Processing enabled package: Thyra (tests, examples)
Processing enabled package: OptiPack (tests, examples)
Processing enabled package: Isorropia (tests, examples)
Processing enabled package: Pliris (tests, examples)
     Building the double precision(default) library
Processing enabled package: AztecOO (tests, examples)
Processing enabled package: Galeri (tests, examples)
Processing enabled package: Amesos (tests, examples)
Processing enabled package: Pamgen (tests, examples)
Processing enabled package: Ifpack (tests, examples)
Processing enabled package: Komplex (tests, examples)
Processing enabled package: ML (tests, examples)
--   WARNING:  Setting ML_ENABLE_Zoltan=OFF since ML_ENABLE_MPI=OFF!
Processing enabled package: Belos (tests, examples)
Processing enabled package: Ifpack2 (tests, examples)
Processing enabled package: Stratimikos (tests, examples)
Processing enabled package: FEI (tests, examples)
Processing enabled package: Anasazi (tests, examples)
Processing enabled package: Intrepid (tests, examples)
Processing enabled package: NOX (tests, examples)
Processing enabled package: Moertel (tests, examples)
Processing enabled package: Rythmos (tests, examples)
Processing enabled package: MOOCHO (tests, examples)
Processing enabled package: Mesquite (tests, examples)
-- Looking for times
-- Looking for times - found
-- Looking for clock
-- Looking for clock - found
-- Looking for cbrt
-- Looking for cbrt - not found
-- Looking for vsnprintf
-- Looking for vsnprintf - found
-- Looking for vsprintf
-- Looking for vsprintf - found
-- Looking for finite
-- Looking for finite - found
-- Looking for _Isfinite
-- Looking for _Isfinite - not found
-- Looking for ieeefp.h
-- Looking for ieeefp.h - not found
-- Looking for ieeefp.h
-- Looking for ieeefp.h - not found
-- Looking for inttypes.h
-- Looking for inttypes.h - found
-- Looking for termios.h
-- Looking for termios.h - found
-- Looking for sys/ioctl.h
-- Looking for sys/ioctl.h - found
-- Looking for dlfcn.h
-- Looking for dlfcn.h - found
-- Looking for fcntl.h
-- Looking for fcntl.h - found

Exporting library dependencies ...

-- Configuring done
-- Generating done
-- Build files have been written to: /home/narendiran/Downloads/trilinos-10.6.3-Build
root at narendiran:/home/narendiran/Downloads/trilinos-10.6.3-Build#


K. Narendiran

On Tue, Apr 5, 2011 at 2:28 PM, Baker, Christopher G. <bakercg at ornl.gov<mailto:bakercg at ornl.gov>> wrote:

Could you send me the output from your configuration? It would be the CMakeCache.txt in the top of your build directory. Specifically, I am interested in seeing the following:
[zan:~/TBUILDS/TPETRA_GPU] ogb% grep COMPLEX_BLAS CMakeCache.txt


On 4/5/11 1:01 AM, "narendiran kumar" <narendirankumar at gmail.com<mailto:narendirankumar at gmail.com><mailto:narendirankumar at gmail.com<mailto:narendirankumar at gmail.com>>> wrote:

Dear Sir/Madam,

This two files (*_Tpetra_MVOPTester) are giving error while i tried to ctest. And also i have attached that error file.

Please help me.

root at narendiran:/home2/trilinos-10.6.3-Source/build# ctest -R ^Anasazi_Tpetra_MVOPTester$ -VV

The following tests FAILED:
487:     4. MultiVector_int_int_ComplexFloat_MVTestDist_UnitTest ...
487: Total Time: 0.895 sec
487: Summary: total = 16, run = 16, passed = 15, failed = 1
487: End Result: TEST FAILED
1/1 Test #487: Anasazi_Tpetra_MVOPTester ........***Failed    1.01 sec

0% tests passed, 1 tests failed out of 1

root at narendiran:/home2/trilinos-10.6.3-Source/build# ctest -R ^Belos_Tpetra_MVOPTester_complex_test$ -VV

The following tests FAILED:
406:     4. MultiVector_int_int_ComplexFloat_MVTestDist_UnitTest ...
406:     5. MultiVector_int_int_ComplexFloat_MVTestLocal_UnitTest ...
406: Total Time: 0.897 sec
406: Summary: total = 16, run = 16, passed = 14, failed = 2
406: End Result: TEST FAILED
1/1 Test #406: Belos_Tpetra_MVOPTester_complex_test ...***Failed    1.00 sec

0% tests passed, 1 tests failed out of 1


On Mon, Apr 4, 2011 at 11:10 PM, Bartlett, Roscoe A <rabartl at sandia.gov<mailto:rabartl at sandia.gov><mailto:rabartl at sandia.gov<mailto:rabartl at sandia.gov>>> wrote:
See info on running CTest at:


in the section "E) Testing with CTest".


> -----Original Message-----
> From: trilinos-users-bounces at software.sandia.gov<mailto:trilinos-users-bounces at software.sandia.gov><mailto:trilinos-users-bounces at software.sandia.gov<mailto:trilinos-users-bounces at software.sandia.gov>> [mailto:trilinos-<mailto:trilinos-><mailto:trilinos-<mailto:trilinos->>
> users-bounces at software.sandia.gov<mailto:users-bounces at software.sandia.gov><mailto:users-bounces at software.sandia.gov<mailto:users-bounces at software.sandia.gov>>] On Behalf Of Baker, Christopher G.
> Sent: Monday, April 04, 2011 11:31 AM
> To: narendiran kumar; trilinos-users at software.sandia.gov<mailto:trilinos-users at software.sandia.gov><mailto:trilinos-users at software.sandia.gov<mailto:trilinos-users at software.sandia.gov>>
> Subject: Re: [Trilinos-Users] ctest -j4 error
> Would you mind trying without "-j4"? If you want to shorten the amount
> of time for testing, you can run the failing tests (plus a few others)
> via:
> ctest -R ".*MVOPTester"
> Thank you.
> Chris
> On 4/4/11 12:25 PM, "narendiran kumar"
> <narendirankumar at gmail.com<mailto:narendirankumar at gmail.com><mailto:narendirankumar at gmail.com<mailto:narendirankumar at gmail.com>><mailto:narendirankumar at gmail.com<mailto:narendirankumar at gmail.com><mailto:narendirankumar at gmail.com<mailto:narendirankumar at gmail.com>>>> wrote:
> Dear Sir/Madam,
> While i was tried "ctest -j4", i got 2 test fail notices.  Can i
> further continue or else i have to solve this problem.
> Please help me.
> Regards,
> K. Narendiran
> 99% tests passed, 2 tests failed out of 730
> Label Time Summary:
> Amesos     =  33.21 sec
> Anasazi    =  85.77 sec
> AztecOO    =   0.90 sec
> Belos      =  58.37 sec
> Epetra     =  24.68 sec
> Komplex    =   0.21 sec
> MOOCHO     = 356.29 sec
> NOX        = 165.30 sec
> Piro       =   4.91 sec
> Rythmos    = 219.58 sec
> Sacado     =  38.80 sec
> Stokhos    =  67.40 sec
> Teuchos    =  10.27 sec
> Total Test time (real) = 267.43 sec
> The following tests FAILED:
>     487 - Anasazi_Tpetra_MVOPTester (Failed)
>     406 - Belos_Tpetra_MVOPTester_complex_test (Failed)
> Errors while running CTest
> _______________________________________________
> Trilinos-Users mailing list
> Trilinos-Users at software.sandia.gov<mailto:Trilinos-Users at software.sandia.gov><mailto:Trilinos-Users at software.sandia.gov<mailto:Trilinos-Users at software.sandia.gov>>
> http://software.sandia.gov/mailman/listinfo/trilinos-users

More information about the Trilinos-Users mailing list