[Trilinos-Users] Linking mumps to Amesos

Jonathan Pitt jsp203 at psu.edu
Tue Dec 9 16:15:25 MST 2008

Dear Trilinos Users and Developers,

I am trying to compile trilinos 9 with amesos and mumps.  I have  
scalapack working within amesos, but would like to get the mumps  
solver working as well.  I am having a problem configuring amesos.   
When checking for the mumps library, I get the following error:

checking whether to use amesos-mumps... yes
checking whether to use amesos-mumps_mpi_c2f... yes
checking whether to use amesos-old_mumps... no
checking whether to use amesos-pardiso... no
checking whether to use amesos-paraklete... no
checking whether to use amesos-taucs... no
checking whether to use amesos-mc64... no
configure: error: Cannot find the double precision MUMPS library,  
specify a location using --with-libs, (ex.  --with-libs=/home/username/ 
lib/libdmumps.a, or use --with-libs=-ldmumps --with-ldflags=-L/hhome/ 
configure: error: ./configure failed for packages/amesos

However, I have the following options on configure:

./configure --prefix=$TRILINOS_DIR (lots of other things)  --enable- 
amesos --enable-amesos-scalapack --enable-amesos-mumps --enable-amesos- 
mumps_mpi_c2f --with-libs="/Users/jpitt/prog/lib/SCALAPACK/ 
libscalapack.a /Users/jpitt/prog/lib/BLACS/LIB/blacsCinit_MPI-OSX-0.a / 
Users/jpitt/prog/lib/BLACS/LIB/blacsF77init_MPI-OSX-0.a /Users/jpitt/ 
prog/lib/BLACS/LIB/blacs_MPI-OSX-0.a /Users/jpitt/prog/lib/MUMPS/lib/ 
libpord.a /Users/jpitt/prog/lib/MUMPS/lib/libdmumps.a" F77=mpif77  
CC=mpicc CXX=mpicxx

The library exists, and I can run the examples with mumps.  I am  
working on an up-to-date intel mac with 10.5.  I am using version  
4.7.3 of mumps (I tried 4.8.3, but it didn't work either, and I saw in  
previous posts that it is not supported yet).

I had a similar problem when trying to install scalapack, and fixed it  
by backing down from scalapack 1.8.0 to 1.7.2.

Does anything look particularly wrong here?  Is there anything special  
I should have in the Makefile.inc to get amesos to recognize the  
library?  Apparently, it is finding the pord library correctly.  I am  
using the same compilers for everything, so I am somewhat confident  
that is not the problem.  What is the configure script checking for  


Jon Pitt

More information about the Trilinos-Users mailing list