[Trilinos-Users] upgrading minimum required version of CMake for Trilinos

Bartlett, Roscoe A rabartl at sandia.gov
Wed Oct 10 18:44:23 EDT 2018


Hello Trilinos Users,

The transition for Trilinos to require CMake 3.10+ on the ‘develop’ branch is now complete.  All Trilinos developers and users will now need to use CMake 3.10+ in order to configure, build, install, and test Trilinos.

Cheers,

-Ross

Dr. Roscoe A. Bartlett, PhD
http://www.cs.sandia.gov/cr-rabartl
Sandia National Laboratories

From: Bartlett, Roscoe A
Sent: Wednesday, September 26, 2018 2:20 PM
To: trilinos-users at trilinos.org
Subject: upgrading minimum required version of CMake for Trilinos

Hello Trilinos Users,

After talking with Jim Willenbring, the new target date for the mandatory upgrade to CMake 3.10 will be October 10, 2018.  After that date, any builds of Trilinos ‘develop’ that don’t use CMake 3.10.0 or newer will crash right away.  (And of course, all releases of Trilinos taken off of the ‘develop’ branch after this will also require CMake 3.10+.)

If you have any questions about this, please see the below Trilinos GitHub issue and contact the Trilinos framework team as described below.

Thanks,

-Ross

Dr. Roscoe A. Bartlett, PhD
http://www.cs.sandia.gov/cr-rabartl
Sandia National Laboratories

From: Trilinos-Users [mailto:trilinos-users-bounces at trilinos.org] On Behalf Of Willenbring, James M
Sent: Tuesday, July 24, 2018 2:44 PM
To: trilinos-users at trilinos.org<mailto:trilinos-users at trilinos.org>
Subject: [EXTERNAL] [Trilinos-Users] upgrading minimum required version of CMake for Trilinos
Importance: High

All,

We are planning to increase the required minimum version of CMake for building Trilinos to 3.10 on or after August 14th.

There are several reasons to update to 3.10, multiple having to do with performance, one to avoid an error, and the newer version also supports the newer single configure, build, test CDash submissions that make building Trilinos for nightly testing much faster. In addition, the increase to 3.10 will allow some TriBITS refactoring to be done to take advantage of some functionality now available in CMake that TriBITS has done itself to this point.

A more comprehensive discussion of the benefits and further information can be found in issue 1761:

https://github.com/trilinos/Trilinos/issues/1761

If you anticipate significant difficulties due to this version increase, please contact the Framework team by mentioning @trilinos/framework in the GitHub issue linked above. CMake version 3.10.3 is available for Linux and Mac on the NFS Mount at Sandia. CMake can also be downloaded and installed from the CMake website:

https://cmake.org/download/

If you are upgrading your version of CMake, we recommend going to the latest version, which is currently 3.12.0.

Thanks

Jim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://trilinos.org/pipermail/trilinos-users/attachments/20181010/ad26e61d/attachment.html>


More information about the Trilinos-Users mailing list