[Trilinos-Users] [EXTERNAL] Trilinos install issue

Bradley, Andrew Michael ambradl at sandia.gov
Thu Jan 19 15:15:20 EST 2017

Hi Josiah,

It appears from the files you sent that CMAKE_AR is not being set. Hence when cmake tests whether it can build a .a file (an archive of .o files), the "ar" part comes up empty:

        /usr/local/cmake/bin/cmake -E cmake_link_script CMakeFiles/VerifyFortran.dir/link.txt --verbose=1
        "" qc libVerifyFortran.a  CMakeFiles/VerifyFortran.dir/VerifyFortran.f.o

The empty quotes should instead of the path to "ar", the system's archiver.

In more detail, in the CMakeCache.txt you sent,
whereas it should be something like
Normally this variable is automatically detected. Since it is not in your case, there's something wrong with the dev environment.

What happens if you type
        $ which ar
Is anything found? Is /usr/bin in $PATH?

It may be that before you can configure Trilinos, you need to work out a few issues with the dev environment. In that case, I recommend working through a few basic cmake example projects. Googling "cmake examples" is helpful. Once you can get a basic project to configure, then go back to configuring Trilinos.


From: Trilinos-Users <trilinos-users-bounces at trilinos.org> on behalf of Du,Yichi <yichidu1993 at ufl.edu>
Sent: Thursday, January 19, 2017 12:27 PM
To: trilinos-users at trilinos.org
Subject: [EXTERNAL] [Trilinos-Users] Trilinos install issue

Dear Sir or Madam,

I tried to install trilinos-11.12.1 on ubuntu-14.04 LTS, it shows a bug and I can't find the solution. This bug is not because of the version of trilinos because I have tried 12.0 and 12.10, they also shows the same bug. Maybe it is very easy but I am totally  a newbie of ubuntu. I attach files to let you know my bug in detail. "do-configure" is the code I input in terminal. The other files are error files. Could you please help me with this issue?

Thank you very much in advance


More information about the Trilinos-Users mailing list