[Trilinos-Users] Spack xsdk installing issue

Osei-Kuffuor, Daniel oseikuffuor1 at llnl.gov
Thu Jan 12 14:30:46 EST 2017

I tried to install xsdk using spack, and the installation fails during the trilinos build. I have tried two different compilers gcc-4.4.7 and gcc-4.9.2 and in both cases, the build fails with the same error. I have included a snippet of the spack install process below. I have also attached the trilinos build log for your convenience. Any help you can provide will be appreciated.


==> No patches needed for trilinos
==> Building trilinos [CMakePackage]
==> Executing phase : 'cmake'
==> Executing phase : 'build'
==> Error: ProcessError: Command exited with status 2:
    'make' '-j32'
/nfs/tmp2/osei/soft/spack/lib/spack/spack/build_systems/cmake.py:116, in build:
     113      def build(self, spec, prefix):
     114          """The usual `make` after cmake"""
     115          with working_dir(self.build_directory()):
  >> 116              inspect.getmodule(self).make()

See build log for details:

Daniel Osei-Kuffuor

Center for Applied Scientific Computing

Lawrence Livermore National Laboratory

Livermore, CA 94550

Mail Code: L-561

Phone: 925-422-7683

Email: oseikuffuor1 at llnl.gov<mailto:oseikuffuor1 at llnl.gov>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://trilinos.org/pipermail/trilinos-users/attachments/20170112/acd888f7/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: trilinos-spack-build.out
Type: application/octet-stream
Size: 2918922 bytes
Desc: trilinos-spack-build.out
URL: <https://trilinos.org/pipermail/trilinos-users/attachments/20170112/acd888f7/attachment-0001.obj>

More information about the Trilinos-Users mailing list