[Trilinos-Users] [EXTERNAL] Trilinos build Teuchos Numerics Error

Bradley, Andrew Michael ambradl at sandia.gov
Sat Dec 24 17:13:14 EST 2016

Hi Rambod,

1. The failed checks are probably OK; those checks don't all need to pass.

2. Did you build your own BLAS using gfortran? If so, I suspect this is just a problem of missing -lgfortran on the link line. Something like this might work to fix that:

    -D BLAS_LIBRARY_NAMES:STRING="blas;gfortran" \
    -D LAPACK_LIBRARY_NAMES:STRING="lapack;blas;gfortran" \

where BLAS_ROOT, LAPACK_ROOT are the directories containing resp. libblas, liblapack (probably the same directory). The idea here is to be very explicit about the libraries to link, and to include in particular libgfortran to resolve the missing symbols.

3. If nothing like that works, you can cd to


in the build directory and run variations on the link line shown by

    cat ./CMakeFiles/teuchosnumerics.dir/link.txt

Try adding -lgfortran after -lblas. The idea here is to try to figure out what's going wrong in the link line directly, without having to rerun cmake repeatedly. Once you get the library to link, then you can put the corresponding fix into you cmake configuration to generate a working link.txt file.

4. If none of that works, you can switch to


and see if you have better luck with a static build. That might push the link issue to your app's link line, and you can add -lgfortran to that line.

5. Finally, not sure, but I think Macs have their own libblas and liblapack (at least with XCode?), so if you find that, you might use the flags in paragraph 2 above to point to these provided libs. They will likely link without need of other libs.


From: Trilinos-Users <trilinos-users-bounces at trilinos.org> on behalf of rambod yousefzadeh tabasi <rambod.tabasi at utexas.edu>
Sent: Friday, December 23, 2016 3:43 PM
To: trilinos-users at trilinos.org
Subject: [EXTERNAL] [Trilinos-Users] Trilinos build Teuchos Numerics Error


I am building trilinos on my new mac. I've tried building several different versions from 11.12 to 12.8 and all return the same error. I realized that during configuration two of the tests related to Teuchos fail and then during make I get an error related to Teuchos numerics. I have attached screen shots of my configuration file and the errors. I would really appreciate any help.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://trilinos.org/pipermail/trilinos-users/attachments/20161224/456847d2/attachment.html>

More information about the Trilinos-Users mailing list