[Trilinos-Users] Tpetra Running Error

Heroux, Mike MHeroux at csbsju.edu
Mon Jan 6 09:37:34 MST 2014


Just asking the obvious:  Did you call MPI_Init before calling any Tpetra functions?

Mike

On Jan 6, 2014, at 12:19 AM, "Sunghwan Choi" <sunghwanchoi91 at gmail.com<mailto:sunghwanchoi91 at gmail.com>> wrote:

Dear Trilinos user,
I am a newbie of tpetra.
I installed tpetra and I tried to test it. But whenever I tried to run it, I got the same message like below

*** The MPI_Comm_set_errhandler() function was called before MPI_INIT was invoked.
*** This is disallowed by the MPI standard.
*** Your MPI job will now abort.
[messi:29111] Local abort before MPI_INIT completed successfully; not able to aggregate error messages, and not able to guarantee that all other processes were killed!
--------------------------------------------------------------------------
mpirun noticed that the job aborted, but has no info as to the process
that caused that situation.
--------------------------------------------------------------------------



What is the problem? If you have any clue, please let me know.


Graduate Student @ Chemistry Department, KAIST (South Korea)
Sunghwan Choi


_______________________________________________
Trilinos-Users mailing list
Trilinos-Users at software.sandia.gov<mailto:Trilinos-Users at software.sandia.gov>
http://software.sandia.gov/mailman/listinfo/trilinos-users



More information about the Trilinos-Users mailing list