[Trilinos-Users] Missing Epetra_MpiSmpComm.h header file

Perschbacher, Brent M bmpersc at sandia.gov
Mon Feb 13 15:19:19 MST 2012


Tiziano,
  I mispoke there. I assumed since 10.8.5 worked for you that the
Epetra_MpiSmpComm.h file was there. I just checked and it is not in the
10.8.5 tarball either. I've also found that it is being excluded on purpose
and has been for a while now. The actual issue is that the header in
question was pulled in to address another bug, but it turns out it wasn't
needed. Unfortunately that header didn't get removed before the release.
Mark Hoemmen has created a fix for it and is currently testing it. We should
have a bug fix release addressing this in the near future. In the mean time
a work around would be to remove the #include "Epetra_MpiSmpComm.h" from
packages/epetraext/src/inout/EpetraExt_HDF5.cpp

Again, sorry for the inconvenience this has caused you.

Thanks for your patience with this,

Brent


On 2/13/12 2:38 PM, "Perschbacher, Brent M" <bmpersc at sandia.gov> wrote:

> Tiziano,
>   As far as I can tell that file should be in the 10.10.0 tarball, however
> it isn't. I will look into this more and hopefully have a fix soon, which
> would be released with the first bug fix release for 10.10.
> 
> In the mean time since that file has been deprecated I would expect that it
> hasn't changed since 10.8.5, you could try copying it from your working
> 10.8.5 as a work around for now.
> 
> Sorry for the trouble with this,
> 
> Brent
> 
> 
> On 2/13/12 2:19 PM, "Mark Hoemmen" <mhoemme at sandia.gov> wrote:
> 
>> On Feb 13, 2012, at 12:00 PM, <trilinos-users-request at software.sandia.gov>
>> wrote:
>>> Message: 1
>>> Date: Sun, 12 Feb 2012 16:39:05 -0500
>>> From: "Tiziano Passerini" <tiziano.passerini at gmail.com>
>>> Subject: [Trilinos-Users] compilation error: Trilinos 10.10.0 and HDF5
>>> To: trilinos-users at software.sandia.gov
>>> Message-ID: <C7AB1DD2-E912-4AFD-8C4E-9B80919E38A3 at gmail.com>
>>> Content-Type: text/plain; charset=us-ascii
>>> 
>>> Dear all,
>>> 
>>> I just downloaded and tried compiling Trilinos 10.10.0. When activating HDF5
>>> support, compilation fails with this error:
>>> 
>>> 
trilinos-10.10.0-Source/packages/epetraext/src/inout/EpetraExt_HDF5.cpp:60:3>>>
3
>>> : error: Epetra_MpiSmpComm.h: No such file or directory
>>> 
>>> I see that Epetra_MpiSmpComm was already declared deprecated in earlier
>>> versions of Trilinos. It looks like that header has been dropped in 10.10.0,
>>> while being still #included in some source files. Is this the case?
>> 
>> Epetra_MpiSmpComm.h is still in the development branch of Trilinos, but the
>> header file is deprecated.  Perhaps it was removed from the 10.10 release so
>> as to prevent 11.0 major release code from depending on it?  Anyway, the code
>> doesn't depend on Epetra_MpiSmpComm, so we should be able to remove it.
>> 
>> Thanks for pointing this out!
>> mfh
>> _______________________________________________
>> Trilinos-Users mailing list
>> Trilinos-Users at software.sandia.gov
>> http://software.sandia.gov/mailman/listinfo/trilinos-users
> 
> 
> _______________________________________________
> Trilinos-Users mailing list
> Trilinos-Users at software.sandia.gov
> http://software.sandia.gov/mailman/listinfo/trilinos-users




More information about the Trilinos-Users mailing list