[Trilinos-Users] SWIG Problems

Matt G mgoodman at email.arizona.edu
Mon Oct 26 23:20:41 MDT 2009


I am compiling trilinos 10 with PyTrilinos.  Are there any workarounds to
the swig related problems reported earlier?

I get the following:

PACKAGE: PyTrilinos
-- Processing enabled package: PyTrilinos (tests, examples)
-- Enabled PyTrilinos modules:
--     Teuchos;Epetra;EpetraExt;IFPACK;Anasazi;ML;NOX
CMake Error at packages/PyTrilinos/cmake/FindSWIG.cmake:53 (MESSAGE):
  SWIG version 1.3.36 is less than required version 1.3.38
Call Stack (most recent call first):
  packages/PyTrilinos/CMakeLists.txt:155 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
meawoppl at leeloo:~/trilinos-10.0.1-Source$ which swig
/usr/local/bin/swig
meawoppl at leeloo:~/trilinos-10.0.1-Source$ swig -version

SWIG Version 1.3.40


Any thoughts?
-Matthew Goodman

=====================
Find me on LinkedIn: http://tinyurl.com/d6wlch
Follow me on twitter: http://twitter.com/meawoppl
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://software.sandia.gov/pipermail/trilinos-users/attachments/20091026/a4c16b9c/attachment.html 


More information about the Trilinos-Users mailing list