[Trilinos-Users] Cygwin Build Problems

Michael Sielemann michael.sielemann at gmail.com
Fri Jan 9 07:57:04 MST 2009

Dear all,
I read through the last six months of compile problem emails on
Trilinos-Users but still have trouble compiling on Cygwin.

Configure works fine with the following flags. Also, I succeed to compile
the libraries. But the examples won't compile.


$ ../configure F77=g77 CC=gcc CXX=g++ --with-gnumake
/C_Sandbox/tribox/atlaslib/lib -lf77blas -lcblas -latlas"
drive/f/C_Sandbox/tribox/atlaslib/lib/ -llapack"
/tribox/trilinoslib/ --enable-didasko --enable-nox --enable-nox-epetra
-nox-examples --cache-file=config.cache
$ make
$ make examples

leads to

Making all in HBMatrices
make[4]: Entering directory
make[4]: *** No rule to make target `GetNecessaryFiles.exe', needed by
make[4]: Leaving directory
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
make[2]: *** [examples] Error 2
make[2]: Leaving directory
Error, the make of target examples failed for the package !
make[1]: *** [examples] Error 2
make[1]: Leaving directory
make: *** [examples] Error 2

Earlier I tried --enable-sacado, too. But then "make everything" complained
was missing, which does not seem to be included in the tar of 9.0.1 nor

Earlier this week, I compiled netlib's LAPACK with g77 and ATLAS following
the guidelines with gcc-4.
Is this incompatible with the Trilinos flags above? I tried to change this
but both

../configure  F77=g77 CC=gcc-4 CXX=g++-4 (...)


../configure  F77=gfortran-4 CC=gcc-4 CXX=g++-4 (...)

report trouble finding BLAS.

checking for dgemm_ in -L/cygdrive/f/C_Sandbox/tribox/atlaslib/lib -lf77blas
-lcblas -latlas... no
checking for dgemm in -L/cygdrive/f/C_Sandbox/tribox/atlaslib/lib -lf77blas
-lcblas -latlas... no
checking for DGEMM in -L/cygdrive/f/C_Sandbox/tribox/atlaslib/lib -lf77blas
-lcblas -latlas... no
checking for DGEMM_ in -L/cygdrive/f/C_Sandbox/tribox/atlaslib/lib -lf77blas
-lcblas -latlas... no
configure: error: Cannot find blas library, specify a path using
/LIB (for example --with-blas=/usr/path/lib/libcxml.a)

I did not find the hints mentioned in the documentation for trouble due to
different compiler versions ("personality error" etc.) so I did not
elaborate more on this.

Does someone have an idea of what is going wrong on my computer?

Thanks, in advance, for any input,

Best regards MICHAEL
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://software.sandia.gov/mailman/private/trilinos-users/attachments/20090109/a9db9295/attachment.html 

More information about the Trilinos-Users mailing list