[Trilinos-Users] FW: compile error

Kurtis Nusbaum klnusbaum at gmail.com
Fri Nov 21 07:14:49 MST 2008

That seemed to do it. I set the environment variable F77 to gfortran and
that worked for the most part. The machine seemed to get stuck at this one
part of building one of the test though. So I just disabled all test and
trilinos compiled fine. Thanks for all your help.

On Tue, Nov 18, 2008 at 8:57 AM, Benjamin Kirk <benjamin.kirk at nasa.gov>wrote:

> >> Thanks for the quick response. I tried enabling epetraext, but now I'm
> >> getting
> >> this problem:
> >> Now building teuchos examples.
> >
> > What are the exact options passed to the configure script? The build log
> > includes '-L/usr/lib/gcc/x86_64-redhat-linux/3.4.6' and
> > '/usr/lib/gcc/x86_64-redhat-linux/4.3.0', it seems it was trying to link
> the
> > compat gcc-3.4.6 libs together with gcc-4.3.0 . The compat gcc-3.4.6 libs
> > shouldn't be needed on Fedora 9.
> I'm willing to bet that you have g77 installed from gcc-3.4.6 and gfortran
> from gcc-4.3.0.  ./configure found g77 first and used it to figure out the
> fortran link libraries, which will not work with a main compiled with
> gcc-4.3
> The fix should be to simply make sure that the underlying fortran compiler
> used is gfortran, whether that be through your mpif77 configuration or
> trilinos' ./configure...
> -Ben
> _______________________________________________
> Trilinos-Users mailing list
> Trilinos-Users at software.sandia.gov
> http://software.sandia.gov/mailman/listinfo/trilinos-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://software.sandia.gov/mailman/private/trilinos-users/attachments/20081121/f9e2f8c9/attachment.html 

More information about the Trilinos-Users mailing list