[Trilinos-Users] Moocho problems...

Luca Heltai luca.heltai at gmail.com
Fri Jun 20 04:36:33 MDT 2008

Hi all,

I tried to modify one of the ThyraModelEvaluator example to solve one  
of my problems, and when I run the code I get the following error  
(from gdb)

*** Start of rSQP Iterations ***
n = 90, m = 40, nz = 0

  k    f         ||c||s    ||rGL||s  QN #act ||Ypy||2 ||Zpz||2 ||d|| 
inf alpha    time(sec)
  ---- --------- --------- --------- -- ---- -------- --------  
-------- -------- ---------
     0         0         -         -  -    -        -        -         
-        -  1.347043

Total time = 1.3471 sec

Oops!  Not the solution.  Some error has occured!

Number of function evaluations:
f(x)  : 0
c(x)  : 0
Gf(x) : 0
Gc(x) : 0

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000000
AbstractLinAlgPack::VectorSpaceThyra::is_in_core (this=0x10933b50)  
at ../../../../../packages/moocho/thyra/src/AbstractLinAlgPack/ 

I tried to spot the exact function that jumps, and I found out that  
it is caused by the call in NLPInterfacePack_NLPThyraModelEvaluatorBase

preprocessBaseInOutArgs( ... )

which calls

model_outArgs.setDgDx( ... ).

I only modified the size of the problem and the fact that I don't  
support derivatives other than W = DfDx. I call the example with

test --moocho-thyra-params-file="thyra_fd.xml"

where thyra_fd.xml switches on the FD calculation of DgDx, DfDp and  
DgDp. A part from this, everything else is exactly the same as the  
example, however the program never gets to the evalModel method...

Any ideas on what could be going wrong?

Thanks in advance.


More information about the Trilinos-Users mailing list