[Trilinos-Users] Trilinos on Mac OSX Leopard

Daniele Avitabile D.Avitabile at surrey.ac.uk
Tue Feb 19 08:59:43 MST 2008


Hi guys,

I have compiled openmpi from scratch: this installs in /usr/local. Doing
a 

"which mpif77"

returns /usr/local/bin, which has the right timestamps. In my configure
script I pass the options

--with-mpi-compilers --with-mpi=/usr/local

I'm beginning to think that also the new installation of openmpi (the
one I build from source) does not enable fortran 77

Thanks.

Daniele


On Tue, 2008-02-19 at 07:46 -0800, Doug Reeder wrote:
> Daniele,
> 
> Are you sure that the trilinos configure is using the openmpi that  
> you created. You may need to put its path at the front of your path  
> or rename the mpi compiler links from the apple supplied openmpi.
> 
> Doug Reeder
> On Feb 19, 2008, at 5:06 AM, Daniele Avitabile wrote:
> 
> > Hi all,
> >
> > I am trying to install Trilinos on a PowerPC running Leopard, and I  
> > will
> > have to do the same very soon on an Mac Intel platform.
> >
> > Did you ever tried to do that? When launching the configure script  
> > (I've
> > done quite a few Trilinos installation, and I'm quite sure the  
> > configure
> > script is fine), it fails to compile a simple fortran program launched
> > by teuchos.
> >
> > Leopard does include built-in ompenmpi wrappers but... not for fortran
> > 77 and fortran 90. You can easily realise that because
> >
> > 1) compiling a hello.f program results in the irritating message
> > ---------------------------------------------------------------------- 
> > ----
> > Unfortunately, this installation of Open MPI was not compiled with
> > Fortran 77 support.  As such, the mpif77 compiler is non-functional.
> >
> > ---------------------------------------------------------------------- 
> > ----
> >
> > 2) in /usr/share/openmpi, where Leopard installed openmpi wrappers,  
> > you
> > can realise that the message above is produced by the file
> > help-opal-wrapper.txt, and that the corresponding f77 file
> > mpif77-wrapper-data.txt has a blank "compiler" field. The same for  
> > f90.
> >
> > Needless to say, I have tried to rebuild openmpi from scratch with
> >
> > ./configure CC=gcc F77=gfortran FC=gfortran CXX=g++; make all install
> >
> > the installation goes fine, but the mpif77 command gives me again the
> > "not compiled with fortran 77 support"
> >
> > Any ideas out there?
> >
> > Best.
> >
> > Daniele
> >
> > _______________________________________________
> > Trilinos-Users mailing list
> > Trilinos-Users at software.sandia.gov
> > http://software.sandia.gov/mailman/listinfo/trilinos-users
> >
> 



More information about the Trilinos-Users mailing list