[Trilinos-Users] Trilinos on Mac OSX Leopard

Bill Spotz wfspotz at sandia.gov
Tue Feb 19 07:35:53 MST 2008


My experience is on both PowerPC and Mac Intel, but only for Mac OS X  
10.4, not yet 10.5 (which has not been approved for use here at  
Sandia yet).

I have generally used fortran compilers installed via fink.  When I  
upgraded from PowerPC to Intel, I had a lot more luck with g95 than  
with gfortran.  I have also use the openmpi provided by fink.  Using  
the Leopard-provided openmpi may be problematic if they do not  
support fortran, as you have observed.

I use the configure option

     --with-ldflags="-L/sw/lib -framework veclib"

where the /sw/lib directory is where the fink fortran libraries can  
be found and "-framework veclib" gives access to the vendor-supplied  


On Feb 19, 2008, at 6:09 AM, Daniele Avitabile wrote:

> Hi all,
> I am trying to install Trilinos on a PowerPC running Leopard, and I  
> will
> have to do the same very soon on an Mac Intel platform.
> Did you ever tried to do that? When launching the configure script  
> (I've
> done quite a few Trilinos installation, and I'm quite sure the  
> configure
> script is fine), it fails to compile a simple fortran program launched
> by teuchos.
> Leopard does include built-in ompenmpi wrappers but... not for fortran
> 77 and fortran 90. You can easily realise that because
> 1) compiling a hello.f program results in the irritating message
> ---------------------------------------------------------------------- 
> ----
> Unfortunately, this installation of Open MPI was not compiled with
> Fortran 77 support.  As such, the mpif77 compiler is non-functional.
> ---------------------------------------------------------------------- 
> ----
> 2) in /usr/share/openmpi, where Leopard installed openmpi wrappers,  
> you
> can realise that the message above is produced by the file
> help-opal-wrapper.txt, and that the corresponding f77 file
> mpif77-wrapper-data.txt has a blank "compiler" field. The same for  
> f90.
> Needless to say, I have tried to rebuild openmpi from scratch with
> ./configure CC=gcc F77=gfortran FC=gfortran CXX=g++; make all install
> the installation goes fine, but the mpif77 command gives me again the
> "not compiled with fortran 77 support"
> Any ideas out there?
> Best.
> Daniele

** Bill Spotz                                              **
** Sandia National Laboratories  Voice: (505)845-0170      **
** P.O. Box 5800                 Fax:   (505)284-0154      **
** Albuquerque, NM 87185-0370    Email: wfspotz at sandia.gov **

More information about the Trilinos-Users mailing list