[Trilinos-Users] Installation Problem;Please Help

James Willenbring jmwille at sandia.gov
Wed Aug 20 07:10:38 MDT 2008


Take --enable-tpetra out of your list of configure options.  We have not yet
released this package, but Thyra has an adapter for the package, so it tries
to find it.  We took tpetra out of the Trilinos level list of packages, and
we don't list it as a release package, but we don't remove adapters for non
release packages because users very rarely activate the adapter switches.
You can also remove --enable-claps because that package has not been
released either.


-----Original Message-----
From: trilinos-users-bounces at software.sandia.gov
[mailto:trilinos-users-bounces at software.sandia.gov] On Behalf Of amjad ali
Sent: Wednesday, August 20, 2008 1:27 AM
To: trilinos-users at software.sandia.gov
Subject: [Trilinos-Users] Installation Problem;Please Help

Hello, I successfully configured trilinos with:

../configure --prefix=/home/trilinos-8.0.8/LINUX_MPI --with-gnumake
--enable-amesos --enable-anasazi --enable-belos --enable-claps
--enable-didasko --enable-external --enable-isorropia --enable-kokkos
--enable-meros --enable-moocho --enable-moertel --enable-rtop
--enable-rythmos --enable-sacado --enable-tpetra --enable-teuchos
--enable-trilinoscouplings --enable-triutils --enable-galeri
--enable-shared  --enable-aztecoo-teuchos
--with-mpi-compilers | tee configure_LINUX_MPI.log

Then I ran command:

make everything | tee make_LINUX_MPI.log

Then comes an error (see ending):
Trilinos package epetraext built successfully
To check the installation, simply type "make run-examples".
For more details, please refer to the instructions
contained in Trilinos/doc/check_installation.txt
make[4]: Leaving directory
make[3]: Leaving directory
Making all in thyra
make[3]: Entering directory `/home/trilinos-8.0.8/LINUX_MPI/packages/thyra'
Making all in src
make[4]: Entering directory
No such file or directory
make[4]: *** No rule to make target
make[4]: Leaving directory
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/trilinos-8.0.8/LINUX_MPI/packages/thyra'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/trilinos-8.0.8/LINUX_MPI/packages'
make[1]: *** [everything] Error 2
make[1]: Leaving directory `/home/trilinos-8.0.8/LINUX_MPI/packages'
make: *** [everything] Error 2
[root at localhost LINUX_MPI]#

I tried ./configure with both --enable-thyra and --disble-thyra. But
no improvement.

Please suggest solution.

with best regards,
Amjad Ali.

Trilinos-Users mailing list
Trilinos-Users at software.sandia.gov

More information about the Trilinos-Users mailing list